[Atualizado em 17/09/2007.]

Flash Player 9

O novo Flash Player 9 (versão 9.0.48.0, de 16/01/2007) para Linux está disponível, bastando instalar o pacote flashplugin-nonfree, no repositório Não-livre (Multiverse) do Ubuntu 7.04 (Feisty Fawn). Flash Player 9 foi também portado retroativamente (backported) para Ubuntu 6.06 LTS e 6.10.

Vídeo e som no Flash Player 9 funcionam de imediato com Firefox 2 do Ubuntu 7.04, sem necessidade de pacotes ou configurações adicionais.

Você deve obter o Flash Player de uma destas fontes:

  • Recomendado: Instalando o pacote flashplugin-nonfree do repositório Não-livre (Multiverse) do Ubuntu, utilizando um gerenciador de pacotes — Synaptic em modo gráfico, aptitude em modo texto, apt-get em linha de comando.
  • Baixando diretamente da Adobe e instalando manualmente, a partir de Adobe Flash Player Centro de download, ou de Adobe Web Player Alternates – Linux.
  • Baixando e instalando manualmente, de macromedia.mplug.org.

Flash Player 7 com Firefox 1.5 e Ubuntu 6.06

Se você tiver instalado o plug-in para Firefox Flash Player 7 Linux (versão 7.0.68 de setembro/2006), para exibir animações e vídeos em Flash dentro do Firefox 1.5 em Linux Ubuntu, recomendo fazer as devidas atualizações de Flash e Firefox.

Nas versões antigas com Ubuntu 6.06 LTS, você pode ter a decepção — como eu tive — de não ter sons reproduzidos e dos vídeos em Flash travarem após tocar apenas 1 ou 2 segundos. Escavando um bocado na Internet, eu encontrei duas soluções distintas. Após aplicar ambas, os fluxos Flash vídeos passaram a tocar continuamente e com som no Firefox 1.5.0.7 do Ubuntu 6.06.

Configurar Firefox para alsa-oss

  1. Instale o pacote alsa-oss. Comando utilizando aptitude:
    $ sudo aptitude install alsa-oss
  2. Edite o arquivo /etc/firefox/firefoxrc e altere o DSP de “none” para “aoss”. Usando o editor gedit, por exemplo:
    $ sudo cp -p /etc/firefox/firefoxrc /etc/firefox/firefoxrc.backup
    $ sudo gedit /etc/firefox/firefoxrc

    FIREFOX_DSP=”aoss”
    
  3. Reinicie o Linux.

Acertar dependências ESD para Flash

  1. Crie o link simbólico /usr/lib/libesd.so.1 da biblioteca procurada pelo Flash:
    $ sudo ln -s /usr/lib/libesd.so.0 /usr/lib/libesd.so.1
  2. Crie um arquivo /tmp/.esd/socket esperado pelo Flash:
    $ sudo mkdir -p /tmp/.esd/
    $ sudo touch /tmp/esd/socket

Depois de tudo configurado, abra o Firefox, navegue por exemplo para YouTube ou Google Video e teste se os fluxos de vídeo em Flash tocam com imagem e som sem problemas.

Para saber mais (em inglês):